• Currently 4.1/5
  • 1
  • 2
  • 3
  • 4
  • 5
4.1/5 (24 votes)
<div class="dialog">This content requires the Unity Web Player<br/><br/><a href="" target="_blank">Install the Unity Web Player today!</a></div>

It's time to prove your Tetris prowess. In this block placing puzzle game with three different modes, fit shapes together on the grid. When you fill a line or column, it disappears. How long can you survive before you run out of room?

Read More


Great, except that the programmer forgot to code the right-click to NOT open the options menu. Every time I rotate a piece, I get the Unity Player options (Fullscreen, About, Setup) which caused me to misplace a couple of tiles and to jump to the "About Unity" page, eliminating all of my progress.


I could not get this to work on unity, which is fine. I like to have my games separate since my screen is so small on my computer. Also it makes that right click thing not a problem.


Unity 5.0 only cam out in March, any idea the minimum needed for this game?

I had no problem playing
Dungeon Warfare, Ascend and Home Improvisation


Just shows up as a blank box for me. This same thing happens with many, but not all, Unity games. Not sure what to do.


I have hopefully resolved the right-click problem. You may need to refresh the game page or clear your cache to view the change. :)

oreilley May 28, 2015 1:40 PM

I kept receiving a "plug-in not supported" message, I have unity installed but I saw Kimberly said Chome no longer supports Unity (?!) sure enough it played fine on Mozilla, thank you Kimberly. A very laid back Tetris-y game...

Bryce Summer May 28, 2015 3:29 PM replied to ChairmanMUHC

Hey, developer here, when a Unity game gets hosted it's up to the site hosting it to specify if the context menu is enabled. This is why I also included the option to use the X key to rotate. Just wanted to clear that up, thanks & I hope you enjoy the game! :)


I am guessing I don't have a high enough version to play this game. 5.0 is not supported on my system so if that is the case I will have to play only the app version. When I open the game it freezes the browser and then a few minutes later Unity crashes.

Does it need Unity 5.0 or higher?

Bryce Summer May 28, 2015 9:06 PM replied to SHA

Yes, the game requires the latest version of Unity Web Player, it was authored in Unity 5.0.2 -- sorry!

SHA May 30, 2015 4:38 AM replied to Bryce Summer

Thank you for replying and letting us know.


^ Scroll Up | Homepage >

Leave a comment [top of page]

Please consider creating a Casual Gameplay account if you're a regular visitor here, as it will allow us to create an even better experience for you. Sign-up here!
  • You may use limited HTML tags for style:
    (a href, b, br/, strong, em, ul, ol, li, code, spoiler)
    HTML tags begin with a less-than sign: < and end with a greater-than sign: >. Always. No exceptions.
  • To post spoilers, please use spoiler tags: <spoiler> example </spoiler>
    If you need help understanding spoiler tags, read the spoiler help.
  • Please Preview your comment before posting, especially when using spoilers!
  • No link dropping, no domains as names; do not spam, and do not advertise! (rel="nofollow" in use)
Dark Romance: Curse of Bluebeard Collector's Edition

Recent Comments


Display 5 more comments
Limit to the last 5 comments

Casual game of the week

Dark Romance: Curse of Bluebeard Collector's Edition

Your Favorite Games edit

Save links to your favorite games here. Use the Favorites editor.

Monthly Archives